Re: PHP OO naming conventions

From: Date: Thu, 15 May 2003 17:48:06 +0000
Subject: Re: PHP OO naming conventions
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-1542@lists.php.net to get a copy of this message
On Thursday, May 15, 2003, at 01:46 PM, Maxim Maletsky wrote:
On Thu, 15 May 2003 13:59:38 +0200 "Lukas Smith" <smith@backendmedia.com> wrote:
I would therefore propose to use studlyCaps as the CS for PHP OO APIs. Current: $foo->execute_query($query, $param);
New:     $foo->executeQuery($query, $param);
I personally don't really like studyCaps as any naming convention in PHP for two reasons: 1. PHP rarely uses it
PHP itself has almost no objects defined in extensions. PEAR does though, and is widely considered to be 'the standard' for writing OO perl. And it has studlyCaps as one of it's CS standards. gs

« previous php.internals (#1542) next »