Re: default exceptions, interfaces, etc.

From: Date: Sun, 23 Mar 2003 00:02:40 +0000
Subject: Re: default exceptions, interfaces, etc.
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-155@lists.php.net to get a copy of this message
Hi, As per naming convention, I think it'd be nice if the methods were named as: getmessage => get_message getcode => get_code If those are corrected, +1 for this feature. Moriyoshi Sterling Hughes <sterling@bumblebury.com> wrote: > Hi, > > Attached is a patch (+ 2 files) that add a default "exception" class to > Zend 2. I find this very useful when you just want to throw a simple > exception inside of a try {}, but you don't want to create a new > exception for each and every error. I'll commit this tommorowish, > unless somebody objects. > > -Sterling > -- > "Whether you think you can or think you can't -- you are right." > - Henry Ford

« previous php.internals (#155) next »