Re: default exceptions, interfaces, etc.
| From: | (Marcus Börger) | Date: | Sun, 23 Mar 2003 02:14:23 +0000 |
| Subject: | Re: default exceptions, interfaces, etc. | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-163@lists.php.net to get a copy of this message | ||
At 00:43 23.03.2003, Sterling Hughes wrote:
On Sat, 2003-03-22 at 19:02, Moriyoshi Koizumi wrote: Hi, As per naming convention, I think it'd be nice if the methods were named as: getmessage => get_message getcode => get_code If those are corrected, +1 for this feature. I was thinking of that - I would personally prefer get_message() and get_code() naming, but that goes against pear's naming conventions, and I want this to integrate well with pear (as a base class.)I agree with moriyoshi here. If pear has a problem with that - than please change pear and do not add more inconsistent featrures instead. The exception class itself was not only once requested. Another point however is the function name zend_register_default_interfaces() in the C code. Since we have interfaces and you do not register an interface with that function you are missleading here so please name that function something like zend_register_default_exceptions() and change the filenames to contain the word exception instead of interfaces. regards marcus