Re: default exceptions, interfaces, etc.
| From: | Jani Taskinen | Date: | Sun, 23 Mar 2003 04:51:20 +0000 |
| Subject: | Re: default exceptions, interfaces, etc. | ||
| References: | 1 2 3 4 5 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-167@lists.php.net to get a copy of this message | ||
On 22 Mar 2003, Sterling Hughes wrote:
>On Sat, 2003-03-22 at 21:33, Derick Rethans wrote:
>> On Sun, 22 Mar 2003, Sterling Hughes wrote:
>>
>> > On Sat, 2003-03-22 at 19:02, Moriyoshi Koizumi wrote:
>> > > Hi,
>> > >
>> > > As per naming convention, I think it'd be nice if the methods were
>> > > named as:
>> > >
>> > > getmessage => get_message
>> > > getcode => get_code
>> > >
>> > > If those are corrected, +1 for this feature.
>> > >
>> >
>> > I was thinking of that - I would personally prefer get_message() and
>> > get_code() naming, but that goes against pear's naming conventions, and
>> > I want this to integrate well with pear (as a base class.)
>>
>> It's a PHP function, not PEAR code, so it should follow the PHP naming
>> style.
>>
>
>As I mentioned to Marcus, there are no naming conventions for OO code,
>only procedural code (in PHP). Also, compliance with PEAR is a
>pragmatic solution, because presumably all their code will be inheriting
>from Exception. The largest, and the official OO library should be
>in-sync with standard practices (and we have none yet regarding OO
>code.)
Even if we don't have specific rules (yet) for OO stuff,
IMO, it should follow the existing rules.
--Jani