Re: default exceptions, interfaces, etc.
| From: | Sterling Hughes | Date: | Sat, 22 Mar 2003 23:43:15 +0000 |
| Subject: | Re: default exceptions, interfaces, etc. | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-156@lists.php.net to get a copy of this message | ||
On Sat, 2003-03-22 at 19:02, Moriyoshi Koizumi wrote:
> Hi,
>
> As per naming convention, I think it'd be nice if the methods were
> named as:
>
> getmessage => get_message
> getcode => get_code
>
> If those are corrected, +1 for this feature.
>
I was thinking of that - I would personally prefer get_message() and
get_code() naming, but that goes against pear's naming conventions, and
I want this to integrate well with pear (as a base class.)
-Sterling
> Moriyoshi
>
> Sterling Hughes <sterling@bumblebury.com> wrote:
>
> > Hi,
> >
> > Attached is a patch (+ 2 files) that add a default "exception" class to
> > Zend 2. I find this very useful when you just want to throw a simple
> > exception inside of a try {}, but you don't want to create a new
> > exception for each and every error. I'll commit this tommorowish,
> > unless somebody objects.
> >
> > -Sterling
> > --
> > "Whether you think you can or think you can't -- you are right."
> > - Henry Ford
--
"People can have the Model T in any colour -- so long as it's black."
- Henry Ford