Re: default exceptions, interfaces, etc.
| From: | Derick Rethans | Date: | Sun, 23 Mar 2003 02:33:44 +0000 |
| Subject: | Re: default exceptions, interfaces, etc. | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-164@lists.php.net to get a copy of this message | ||
On Sun, 22 Mar 2003, Sterling Hughes wrote:
> On Sat, 2003-03-22 at 19:02, Moriyoshi Koizumi wrote:
> > Hi,
> >
> > As per naming convention, I think it'd be nice if the methods were
> > named as:
> >
> > getmessage => get_message
> > getcode => get_code
> >
> > If those are corrected, +1 for this feature.
> >
>
> I was thinking of that - I would personally prefer get_message() and
> get_code() naming, but that goes against pear's naming conventions, and
> I want this to integrate well with pear (as a base class.)
It's a PHP function, not PEAR code, so it should follow the PHP naming
style.
Derick
--
"my other box is your windows PC"
-------------------------------------------------------------------------
Derick Rethans http://derickrethans.nl/
PHP Magazine - PHP Magazine for Professionals http://php-mag.net/
-------------------------------------------------------------------------