Re: ext/filter, Final API proposal
| From: | Dan Scott | Date: | Sat, 16 Sep 2006 17:28:58 +0000 |
| Subject: | Re: ext/filter, Final API proposal | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-25737@lists.php.net to get a copy of this message | ||
On 16/09/06, Ilia Alshanetsky <ilia@prohost.org> wrote:
On 16-Sep-06, at 11:35 AM, Dan Scott wrote: Minor: the general structure of the function names are <prefix>_<verb>_<noun>, so it would be more consistent if this was 'input_list_filters'. Overall: +1 (with bonus points if you go with <prefix>_<verb>_<noun> for the two identified cases) I for one think we should try to keep the names of something that (hopefully) will be used often as short possible to reduce the likely hood of typos. Ilia AlshanetskyAgreed. input_id_filter() is shorter than input_name_to_filter(), and input_list_filters() is the same length as input_filters_list(). Dan