RE: [PHP-DEV] ext/filter, Final API proposal
| From: | Andi Gutmans | Date: | Sun, 17 Sep 2006 01:18:41 +0000 |
| Subject: | RE: [PHP-DEV] ext/filter, Final API proposal | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-25740@lists.php.net to get a copy of this message | ||
Yep I agree. I thought the idea was to go to filter_* which has been our
standard for extensions.
I'm sure we can find good names for the functions in this way.
> -----Original Message-----
> From: Ilia Alshanetsky [mailto:iliaal@gmail.com] On Behalf Of
> Ilia Alshanetsky
> Sent: Saturday, September 16, 2006 10:36 AM
> To: Dan Scott
> Cc: pierre.php@gmail.com; internals@lists.php.net;
> derick@php.net; rasmus@php.net
> Subject: Re: [PHP-DEV] ext/filter, Final API proposal
>
>
> On 16-Sep-06, at 1:28 PM, Dan Scott wrote:
> > Agreed. input_id_filter() is shorter than
> input_name_to_filter(), and
> > input_list_filters() is the same length as input_filters_list().
>
> Why not change the function prefixes to filter_*, which in
> turn allows for MUCH shorter name,
> Ex: input_list_filters -> filter_list()
>
> Ilia Alshanetsky
>
> --
> PHP Internals - PHP Runtime Development Mailing List To
> unsubscribe, visit: http://www.php.net/unsub.php
>