Re: ext/filter, Final API proposal
| From: | Ilia Alshanetsky | Date: | Sun, 17 Sep 2006 15:59:48 +0000 |
| Subject: | Re: ext/filter, Final API proposal | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-25745@lists.php.net to get a copy of this message | ||
On 16-Sep-06, at 9:27 PM, Pierre wrote:
Hello, On 9/17/06, Andi Gutmans <andi@zend.com> wrote:These looks good. The only other suggestion is to explore the option of renaming filter_get_args() to filter_get_variable() so it is a bit more consistent with filter_has_variable(). Ilia AlshanetskyYep I agree. I thought the idea was to go to filter_* which has been our standard for extensions. I'm sure we can find good names for the functions in this way.old name > new name:input_get > filter_get input_get_args > filter_get_argsinput_has_variable > filter_has_variablenput_ filters_ list > filter_list()input_name_to_filter > filter_id(name)