Re: ext/filter, Final API proposal

From: Date: Sun, 17 Sep 2006 11:39:20 +0000
Subject: Re: ext/filter, Final API proposal
References: 1 2 3  Groups: php.internals 
Request: Send a blank email to internals+get-25742@lists.php.net to get a copy of this message
At 04:27 17/09/2006, Pierre wrote:
Hello, On 9/17/06, Andi Gutmans <andi@zend.com> wrote:
Yep I agree. I thought the idea was to go to filter_* which has been our standard for extensions. I'm sure we can find good names for the functions in this way.
old name > new name:
input_get              > filter_get
input_get_args      > filter_get_args
input_has_variable > filter_has_variable
nput_ filters_ list    > filter_list()
input_name_to_filter > filter_id(name) is it ok? I think we all agree on the signatures and behaviors of input_get and input_get_args (or whatever their new names will be).
Looks good. Zeev

« previous php.internals (#25742) next »