Re: ext/filter, Final API proposal
| From: | Dan Scott | Date: | Sun, 17 Sep 2006 13:30:41 +0000 |
| Subject: | Re: ext/filter, Final API proposal | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-25744@lists.php.net to get a copy of this message | ||
On 16/09/06, Pierre <pierre.php@gmail.com> wrote:
Hello, On 9/17/06, Andi Gutmans <andi@zend.com> wrote: Yep I agree. I thought the idea was to go to filter_* which has been our standard for extensions. I'm sure we can find good names for the functions in this way. old name > new name:I like it. Short and to the point. Daninput_get > filter_get input_get_args > filter_get_argsinput_has_variable > filter_has_variablenput_ filters_ list > filter_list()input_name_to_filter > filter_id(name) is it ok? I think we all agree on the signatures and behaviors of input_get and input_get_args (or whatever their new names will be). --Pierre