Re: [RFC] Implicit isset() in Shorthand Ternary Operator

From: Date: Wed, 17 Sep 2014 16:40:26 +0000
Subject: Re: [RFC] Implicit isset() in Shorthand Ternary Operator
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-77297@lists.php.net to get a copy of this message
Hi Andrea, This is great -- thanks to you and Nikita for the work here. Syntax wise, I would prefer a function-like syntax, e.g. coalesce($a, $b, 'c') or ifsetor() instead of $a ?? $b ?? 'c'. I find this more readable, and it avoids any possible confusion about precedence within the expressions. Either way, still +1 for this feature. Best regards, --Matthew

« previous php.internals (#77297) next »