Re: [RFC] UString

From: Date: Thu, 23 Oct 2014 08:44:19 +0000
Subject: Re: [RFC] UString
References: 1 2 3 4 5  Groups: php.internals 
Request: Send a blank email to internals+get-78263@lists.php.net to get a copy of this message
this won't completely solve the problem, because array keys won't be UString anymore. Thanks. Dmtiry. On Thu, Oct 23, 2014 at 12:11 PM, Joe Watkins <pthreads@pthreads.org> wrote: > On Tue, 2014-10-21 at 10:30 -0700, Stas Malyshev wrote: > > Hi! > > > > > I wish there was a way for specific objects to opt into this. > > > > There will be, if __hashKey() or whatever would be the properly > > bikeshedded name, becomes reality as discussed elsewhere. It shouldn't > > be hard to do and it's exactly what many other languages do when trying > > to use objects as keys for maps. > > > > > > Not ready for discussion yet ... > > https://wiki.php.net/rfc/hashkey > > But it exists, I think it solves a problem for ustring in particular but > it solves the problem in general too. No time to write about it or > discuss it at this moment, but in pipeline, hopefully ... > > Cheers > Joe > >

« previous php.internals (#78263) next »