Re: [RFC] UString
| From: | Andrea Faulds | Date: | Thu, 23 Oct 2014 20:18:29 +0000 |
| Subject: | Re: [RFC] UString | ||
| References: | 1 2 3 4 5 6 7 8 9 10 11 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-78282@lists.php.net to get a copy of this message | ||
> On 23 Oct 2014, at 20:54, Stas Malyshev <smalyshev@sugarcrm.com> wrote:
>
>> P.S. u() is a bad name, will break lots of code, i.e.
>
> Maybe __u()? It's a bit ugly but you're not allowed to use __ so it's safe..
I don't like that. This might sound crazy, but what about adding Unicode string literals to the
parser, e.g. u"foo bar\u{202e}你好"? If the UString extension isn't available, just
error. It wouldn't be the first time we had disableable syntax features (``), and this avoids
any possible conflicts.
--
Andrea Faulds
http://ajf.me/