Re: [RFC] UString
| From: | Joe Watkins | Date: | Fri, 24 Oct 2014 06:03:05 +0000 |
| Subject: | Re: [RFC] UString | ||
| References: | 1 2 3 4 5 6 7 8 9 10 11 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-78291@lists.php.net to get a copy of this message | ||
On Thu, 2014-10-23 at 12:54 -0700, Stas Malyshev wrote:
> Hi!
>
> > P.S. u() is a bad name, will break lots of code, i.e.
>
> Maybe __u()? It's a bit ugly but you're not allowed to use __ so it's safe.
>
/me cringes ...
I wonder how much of a problem it really is, usually when we say some
function name is a problem is because of hundreds and hundreds of
results on github.
If it's a huge problem then we should rename it, if we have to dig
around for a single project that's incompatible, or even a handful, then
it's not really a problem.
Cheers
Joe