Re: [RFC] [VOTE] pecl_http
| From: | Tony Marston | Date: | Sat, 31 Jan 2015 09:57:26 +0000 |
| Subject: | Re: [RFC] [VOTE] pecl_http | ||
| References: | 1 2 3 4 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-81476@lists.php.net to get a copy of this message | ||
"Yasuo Ohgaki" wrote in message news:CAGa2bXZGLjrp6i2VDnkdgA8Dw7NothC9iE17tsT40kpbbhA9FA@mail.gmail.com...
Hi Tony, On Fri, Jan 30, 2015 at 7:08 PM, Tony Marston <TonyMarston@hotmail.com> wrote:<snip>>""Pavel Kouril"" wrote in message news:CAB6YZuzyMBAa5i3f9NsvebG2B7YJvO4RyVpy-eac78rsOJxdhQ@mail.gmail.com...We have coding standard. From the CODING_STANDARDS in source. 6. Method names follow the 'studlyCaps' (also referred to as 'bumpy case' or 'camel caps') naming conventionOn Wed, Jan 28, 2015 at 1:17 PM, Michael Wallner <mike@php.net> wrote:<snip>> Hello,just one observation - would be the name of the classes and namespaces stay the same after merging? I personally find the lowercased namespace name kinda weird, given that most of code written in PHP I've seen is using CamelCase.Just because that most of the code YOU have seen uses CamelCase does not mean that CamelCase is the "standard". I programmed in other languages for over 20 years before I switched to PHP, and in those languages the standard was snake_case. That is the standard I still use, and I will object most strongly to the notion that I should change the habits of a lifetime just to suit the personal preferences of a junior programmer. By "junior" I mean "years of experience", not "job title".
7. Classes should be given descriptive names. Avoid using abbreviations where possible. Each word in the class name should start with a capital letter, without underscore delimiters (CamelCaps starting with a capital letter). The class name should be prefixed with the name of the 'parent set' (e.g. the name of the extension):: <<snip>>If you are talking about coding standards which apply to PHP core then that is one thing, but trying to enforce those standards in userland code would be completely unacceptable. -- Tony Marston