Re: [PEPr] Call for votes on Authentication::Auth_HTTP_Digest
| From: | Rui Hirokawa | Date: | Sat, 28 Feb 2004 14:22:01 +0000 |
| Subject: | Re: [PEPr] Call for votes on Authentication::Auth_HTTP_Digest | ||
| References: | 1 2 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-25951@lists.php.net to get a copy of this message | ||
I just made Auth_HTTP.php including HTTP Digest Authentication.
Auth_HTTP:
http://www.geocities.jp/rui_hirokawa/php/scripts/HTTP.php.txt
sample file for digest authentication:
http://www.geocities.jp/rui_hirokawa/php/scripts/test-digest.php.txt
I believe that the basic authentication works just as the current
version and it has same API.
I would cancel my proporsal for Auth_HTTP_Digest at pepr.
Rui
On Sat, 28 Feb 2004 09:45:07 +0100
Martin Jansen <mj@php.net> wrote:
> On Sat Feb 28, 2004 at 11:5821AM +0900, Rui Hirokawa wrote:
> > I could integrate Auth_HTTP_Digest into Auth_HTTP package.
>
> That's great news!
>
> > There two different method for the integration because Auth_HTTP_Digest
> > also supports Basic Authentication.
> >
> > - add Auth_HTTP_Digest.php into Auth_HTTP package.
> > - replace Auth_HTTP with Auth_HTTP_Digest.
> >
> > Which is better ?
>
> I'm not really sure. On the one hand I'd like to keep the API of
> Auth_HTTP as it is today, but on the other hand it would of course be
> cool to have Digest authentication directly in Auth_HTTP.
>
> So do you think there is any chance to keep the current API and at the
> same time incorporate Digest authentication?
>
> > I could be a maintainer of Auth_HTTP package to support digest authentication ?
>
> Sure. I did not have much time for Auth_HTTP lately.
>
> > And, in the current implementation, password verify process is included
> > in fetchData method of container class.
> >
> > I think container and verification should be clearly divided and
> > verifyPassword() should be called from Auth class itself, not from
> > container class.
> >
> > I suggest that
> > fetchData($username, $password) of container class of should be
> > fetchData($username) to divide verification from container.
>
> This seems to make sense for me. But you should actually negotiate that
> with the maintainer of Auth, Yavor Shahpasov, because the containers are
> all taken from the Auth package.
>
> --
> - Martin Martin Jansen
> http://martinjansen.com/
>
> --
> PEAR Development Mailing List (http://pear.php.net/)
> To unsubscribe, visit: http://www.php.net/unsub.php
--
Rui Hirokawa <rui_hirokawa@ybb.ne.jp>