Re: [PEPr] Call for votes on Authentication::Auth_HTTP_Digest

From: Date: Sat, 28 Feb 2004 02:58:21 +0000
Subject: Re: [PEPr] Call for votes on Authentication::Auth_HTTP_Digest
References: 1 2  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-25946@lists.php.net to get a copy of this message
Martin, I changed my opinion, I could integrate Auth_HTTP_Digest into Auth_HTTP package. There two different method for the integration because Auth_HTTP_Digest also supports Basic Authentication. - add Auth_HTTP_Digest.php into Auth_HTTP package. - replace Auth_HTTP with Auth_HTTP_Digest. Which is better ? I could be a maintainer of Auth_HTTP package to support digest authentication ? And, in the current implementation, password verify process is included in fetchData method of container class. I think container and verification should be clearly divided and verifyPassword() should be called from Auth class itself, not from container class. I suggest that fetchData($username, $password) of container class of should be fetchData($username) to divide verification from container. It is because some kind of authentication methods such as digest authentication are depend on user's input, and it is very hard to support the various containers with current implementation. Rui On Fri, 27 Feb 2004 14:46:23 +0100 Martin Jansen <mj@php.net> wrote: > On Fri Feb 27, 2004 at 01:3300PM -0000, PEPr wrote: > > Rui Hirokawa (http://pear.php.net/user/hirokawa) has initiated the > > call for votes on the package Authentication::Auth_HTTP_Digest. > > I may have missed the initial discussion about that, but is there any > way to integrate this into Auth_HTTP instead of putting this stuff in an > independent package? > > -- > - Martin Martin Jansen > http://martinjansen.com/ -- Rui Hirokawa <rui_hirokawa@ybb.ne.jp>

« previous php.pear.dev (#25946) next »