Re: hope to finish the coding standard
| From: | Peter Bowyer | Date: | Fri, 21 Dec 2001 11:00:58 +0000 |
| Subject: | Re: hope to finish the coding standard | ||
| References: | 1 2 3 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-3646@lists.php.net to get a copy of this message | ||
At 06:48 AM 12/21/01 +0100, Tomas V.V.Cox wrote:
That takes us to c): methodName() vs method_name()What exactly is the basis for using one instead of the other? One is more readable? One follows the languages we have most used (eg C, Java)? There doesn't seem to be a good reason to choose either :-) I personally find name_this() more readable than nameThis(), but PEAR uses the latter. Do others??? However, code written using studleyCaps is more pleasing to the eye (less whitespace). No I haven't got any solution for this discussion :-) Peter. -- Maple Design - http://www.mapledesign.co.uk