[PEPr] Comment on File System::File_Mogile
| From: | Chuck Burgess | Date: | Thu, 31 Jan 2008 01:38:55 +0000 |
| Subject: | [PEPr] Comment on File System::File_Mogile | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-49028@lists.php.net to get a copy of this message | ||
Chuck Burgess (http://pear.php.net/user/ashnazg) has commented on the proposal for File
System::File_Mogile.
Comment:
Check your license tags... they link to BSD, but docblock text says PHP
license.
If PEAR.php does indeed end up being needed by the exception (as the code
comment says), maybe the exception class file would be a better place to
put the require_once('PEAR.php') line.
Maybe rename private function request() to _request(), to follow the
naming convention of your other private function _store(). That probably
means I should also hint at renaming your private vars $_socket and
$_domain. Actually, why are the two timeout vars public?
Sounds like we're giving you lots of nitpick-the-details comments, which
probably means the overall package idea is good, its API looks fine, and we
reviewers are left to just be human Codesniffers :)
Proposal information:
http://pear.php.net/pepr/pepr-proposal-show.php?id=528
--
Sent by PEPr, the automatic proposal system at http://pear.php.net