Re: [PEPr] Comment on File System::File_Mogile
| From: | Bill Shupp | Date: | Thu, 31 Jan 2008 02:05:41 +0000 |
| Subject: | Re: [PEPr] Comment on File System::File_Mogile | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-49030@lists.php.net to get a copy of this message | ||
Chuck Burgess wrote:
Maybe rename private function request() to _request(), to follow the naming convention of your other private function _store(). That probably means I should also hint at renaming your private vars $_socket and $_domain. Actually, why are the two timeout vars public?While the above comment is more about consistent naming conventions within File_Mogile, it reminded me of a question I had about this CS manual entry: http://pear.php.net/manual/en/standards.naming.php It states that for PHP5, protected members not preceded by an underscore since PHP5 supports visibility. But, it doesn't mention private members in PHP5. Should they always have an underscore prefix? I don't see a need to, and it seems like an oversight in the documentation. Could someone clarify? Thanks! Bill Shupp