Re: Output_Cache Module

From: Date: Thu, 22 Feb 2001 14:56:22 +0000
Subject: Re: Output_Cache Module
Groups: php.pear 
Request: Send a blank email to php-pear+get-1447@lists.php.net to get a copy of this message
Quoting Ulf Wendel <ulf.wendel@phpdoc.de>: > class storage > > public: > > mixed get(id) > boolean save(id, data) > boolean delete(id) > boolean flush() > boolean isCached(id) > boolean isExpired(id) > > [ > private: > string load(id) > ] ... except that this isn't a generic storage class, it's an API for cache backends. So it should be called CacheDriver, or just Cache_File, Cache_SQL, etc. - much less misleading. You can use a factory approach like DB to instantiate Cache objects. -chuck -- Charles Hagenbuch, <chuck@horde.org> "We have no fuel on board, plus or minus 8 kilograms." -A NASA scientist

« previous php.pear (#1447) next »