Re: convention about function naming II

From: Date: Sun, 17 Dec 2000 18:36:15 +0000
Subject: Re: convention about function naming II
References: 1  Groups: php.dev php.qa 
Request: Send a blank email to php-dev+get-41683@lists.php.net to get a copy of this message
On Sun, Dec 17, 2000 at 07:19:48PM +0100, André Langhorst wrote: > c) I would suggest not to use very long function names to make people > angry eg. > "filepro","ingres","opensll","ovrimos","satellite" > - I > personally prefer using "fp","ingr","ossl","ovr" or > "sat" is there any > convention about this? There was some time a consensus, to use longer names. Example "ii" is too short and "ingres_ii" is to long. "ingres" is the name we use now and it is very known to the majority of user of that database. > 2) unconventional function naming caught: > > a) ctype - already mentioned in README that the author (Harmut) does not > know if adding a prefix or using C-Names is preferable, I think both are > valid I know Hartmut very well. It seems he is knowing himself what he is doing. > b) exif - read_exif_data (only one function) It will be more functions in the near future. > c) sockets I hope you will not introduce the naming scheme from PHP/FI? MySQL function names look to me ok. -Egon -- http://www.linuxtag.de/ http://php.net/books.php http://www.concert-band.de/

« previous php.dev (#41683) next »