Re: Re: convention about function naming II
| From: | Andi Gutmans | Date: | Tue, 19 Dec 2000 16:28:14 +0000 |
| Subject: | Re: Re: convention about function naming II | ||
| References: | 1 2 3 4 | Groups: | php.dev php.qa |
| Request: | Send a blank email to php-dev+get-41869@lists.php.net to get a copy of this message | ||
I really want these name changes to make it into 4.0.4 or we'll be left with backwards compatibility problems when releasing 4.0.5.
Sascha, I think we should have one last RC. We will end up having to keep two versions of the function names which sucks.
Andi
At 13:02 19/12/00 +0100, Hartmut Holzgraefe wrote:
i've now changed the developement branch accordingly (including the regression tests) what is the current policy regarding the RC-Branch? Zeev Suraski wrote: Yes, definitely. Zeev At 18:25 18/12/2000, Andi Gutmans wrote:--- Andi Gutmans <andi@zend.com> http://www.zend.com/I prefer making function name changes *before* people use them. Also you're unlikely to break stuff. I would put it in 4.0.4. Andi At 15:40 18/12/00 +0100, Hartmut Holzgraefe wrote:-- Hartmut Holzgraefe hartmut@six.de http://www.six.de +49-711-99091-77ctype is an execption in that it provides some functions that are in very common use in C so that they might perhpas deserve to keep their names that we are all used to, but on the other hand they do collide with the variable information functions like isset() or is_string() so i did want to rename theese to ctype_*() but didn't make it in time before the 4.0.4RCs where rolled out, so it's C-ish style for now but both the README and the EXPERIMENTAL files in ext/ctype say that changes may still happen, so it's not finally decided yet ... (thats what the EXPERIMENTAL files are for anyway ...)