Re: convention about function naming II

From: Date: Mon, 18 Dec 2000 14:40:43 +0000
Subject: Re: convention about function naming II
References: 1 2  Groups: php.dev php.qa 
Request: Send a blank email to php-dev+get-41747@lists.php.net to get a copy of this message
eschmid+sic@s.netic.de wrote: > > 2) unconventional function naming caught: > > > > a) ctype - already mentioned in README that the author (Harmut) does not > > know if adding a prefix or using C-Names is preferable, I think both are > > valid > > I know Hartmut very well. It seems he is knowing himself what he is doing. ctype is an execption in that it provides some functions that are in very common use in C so that they might perhpas deserve to keep their names that we are all used to, but on the other hand they do collide with the variable information functions like isset() or is_string() so i did want to rename theese to ctype_*() but didn't make it in time before the 4.0.4RCs where rolled out, so it's C-ish style for now but both the README and the EXPERIMENTAL files in ext/ctype say that changes may still happen, so it's not finally decided yet ... (thats what the EXPERIMENTAL files are for anyway ...) -- Hartmut Holzgraefe hartmut@six.de http://www.six.de +49-711-99091-77

« previous php.dev (#41747) next »