Re: Re: convention about function naming II

From: Date: Mon, 18 Dec 2000 17:18:03 +0000
Subject: Re: Re: convention about function naming II
References: 1 2 3  Groups: php.dev php.qa 
Request: Send a blank email to php-dev+get-41794@lists.php.net to get a copy of this message
Yes, definitely. Zeev At 18:25 18/12/2000, Andi Gutmans wrote:
I prefer making function name changes *before* people use them. Also you're unlikely to break stuff. I would put it in 4.0.4. Andi At 15:40 18/12/00 +0100, Hartmut Holzgraefe wrote:
eschmid+sic@s.netic.de wrote: 2) unconventional function naming caught: a) ctype - already mentioned in README that the author (Harmut) does not know if adding a prefix or using C-Names is preferable, I think both are valid
I know Hartmut very well. It seems he is knowing himself what he is doing.
ctype is an execption in that it provides some functions that are in very common use in C so that they might perhpas deserve to keep their names that we are all used to, but on the other hand they do collide with the variable information functions like isset() or is_string() so i did want to rename theese to ctype_*() but didn't make it in time before the 4.0.4RCs where rolled out, so it's C-ish style for now but both the README and the EXPERIMENTAL files in ext/ctype say that changes may still happen, so it's not finally decided yet ... (thats what the EXPERIMENTAL files are for anyway ...) -- Hartmut Holzgraefe hartmut@six.de http://www.six.de +49-711-99091-77 -- PHP Quality Assurance Mailing List <http://www.php.net/> To unsubscribe, e-mail: php-qa-unsubscribe@lists.php.net For additional commands, e-mail: php-qa-help@lists.php.net To contact the list administrators, e-mail: php-list-admin@lists.php.net
--- Andi Gutmans <andi@zend.com> http://www.zend.com/ -- PHP Development Mailing List <http://www.php.net/> To unsubscribe, e-mail: php-dev-unsubscribe@lists.php.net For additional commands, e-mail: php-dev-help@lists.php.net To contact the list administrators, e-mail: php-list-admin@lists.php.net
-- Zeev Suraski <zeev@zend.com> CTO & co-founder, Zend Technologies Ltd. http://www.zend.com/

« previous php.dev (#41794) next »