Re: Woah

From: Date: Sat, 08 Sep 2001 02:40:15 +0000
Subject: Re: Woah
References: 1 2 3 4 5  Groups: php.dev 
Request: Send a blank email to php-dev+get-65417@lists.php.net to get a copy of this message
Quoting Zeev Suraski <zeev@zend.com>: > >It also makes gettext useable. > > I don't buy that. 'gettext' is hardly the only token that's used > repeatedly throughout PHP, and we never made any exceptions anywhere > else. It's the kind of thing that gets used a lot in HTML, where otherwise there wouldn't be a function call at _all_ - just static text. Replacing gettext() with _() in this case actually does improve readability, in my opinion. > > It's documented, for what it's worth: > >http://www.php.net/manual/en/function.gettext.php > > That's unfortunate. IMHO, it should be phased out. Exceptions in php extensions have been made before where the extension mirrors the c library exactly, in order to not confuse people familiar with the library. This is another one of those cases - people familiar with gettext will be very confused if _() doesn't work the way they expect it to. -chuck -- Charles Hagenbuch, <chuck@horde.org> Some fallen angels have their good reasons.

« previous php.dev (#65417) next »