Re: Woah

From: Date: Tue, 11 Sep 2001 03:24:01 +0000
Subject: Re: Woah
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-65746@lists.php.net to get a copy of this message
Quoting Steve Langasek <vorlon@netexpress.net>:

> So I'm all for removing _() from the gettext extension... but I think the
> people who are so eager for this have a responsibility to make sure PHP has a
> good option for user-aliasing of functions in place before it goes away.

I think if something like this had been suggested in the first place, instead 
of the all-out annihilate _() warfare that took place (and yes, I am guilty of 
responding in kind), we might have had a much shorter discussion. Something to 
consider for the future. :)

I would be happy with this kind of solution (removing _() after there is a user-
space alias_function() call which can create a new name for a PHP function). I 
would be even happier if calling alias_function('gettext', '_') would simply do 
nothing if _() already pointed to gettext(), but I won't quibble about the 
function_exists() check.

-chuck

--
Charles Hagenbuch, <chuck@horde.org>
Some fallen angels have their good reasons.


Thread (121 messages)

« previous php.dev (#65746) next »