Re: Woah

From: Date: Mon, 10 Sep 2001 21:31:34 +0000
Subject: Re: Woah
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-65700@lists.php.net to get a copy of this message
The point that *I* have been trying to get at is that this has *ALWAYS* been a bad idea, no matter what langague you are using. You all talk an awful lot about how _ decreases the "contextual overhead". What I'm trying to express is that THIS IS BAD! gettext() is deep magic. When you are doing deep magic, every single thing you can do to make people MORE aware of what that magic relates to is a GOOD THING. I would love if every C developer in the world would stop using this. I doubt that's going to happen anytime soon...but at least I can voice my opinion here, what people at least hear me out, if they don't exactly *hear* me. :) It's a bad idea. Always. No matter what language you are using. No matter what kind of library you are talking about. Making things this complex into such an easy thing to overlook is a good way to hurt and frustrate your users, and your fellow coders. Is gettext() *REALLY* that hard to type? I find that really, really hard to believe. Sorry, I know I'm descending once again, but I have lost quite a bit of time trying to figure out what _ was (in C, not in PHP). I want to save others that pain and frustration if at all possible. > I don't think deprecating it will make the problem go away: people will > still use it because a) all their other code uses it and b) thats the > way you do things with gettext c) A page full of the word gettext is > certainly harder for a person to parse and read the meaning of their > localized text than an inobtrusive _ character. > > So, if we remove the falias people will still put their own in and all the > PHP code will end up looking the same so the net effect is that we have > slowed down the PHP code, added a function and not changed the readability > or namespace pollution. > > So what exactly are we arguing about^H^H^H^H^H^H^H^H^H^H^H^H^H discussing > here? That _() is evil and should go, or that we definitely don't want > anything else like it in the future? > I think/hope that it is the latter.

« previous php.dev (#65700) next »