Does this mean we can forget namespaces then?
Is this where we have come to: blackmail ?
--Jani
On Sat, 8 Sep 2001, Zeev Suraski wrote:
Fine.
Let it be noted that I oppose going forward with any other clean-up of the
language namespace before this bug goes away. If we don't clean the
obvious ones, we might as well keep in everything.
(a very disappointed) Zeev
At 15:51 08-09-01, Stig Sæther Bakken wrote:
[Zeev Suraski <zeev@zend.com>]
At 09:13 08-09-01, Andrei Zmievski wrote:
At 05:33 AM 9/8/01 +0300, Zeev Suraski wrote:
That's unfortunate. IMHO, it should be phased out.
I'm against it. _() has been around forever as part of gettext
package and people who expect to find it in PHP will be pretty
disappointed.
Disappointment isn't exactly the metrics here. People who migrate
from other languages will be disappointed not to find all sorts of
things they're used to from their old languages, but it has never been
a reason to obscure PHP.
_() has no room in PHP's naming convention. There's a small downwards
compatibility issue (it's not advertised very promptly), so we should
deprecate it just like we deprecate and have deprecated other
functions in the past.
Hey, let's just leave it, please. There's a zillion people who use
this now, it's what they expect if they have used gettext before.
It's been here for 2.5 years, it hasn't bothered anyone until now, and
I don't think removing it would be anything less than counter-
productive. Removing it would only make people alias _ to gettext
themselves, net result being i18n'ed code running slower. It's not
like we're going to add more single-character aliases, so I don't buy
the feature creep argument either.
L_A! (leave _ alone!)
- Stig
--
Stig Sæther Bakken <ssb@alltheweb.com>
Fast Search & Transfer ASA, Trondheim, Norway
--
PHP Development Mailing List <
http://www.php.net/>
To unsubscribe, e-mail: php-dev-unsubscribe@lists.php.net
For additional commands, e-mail: php-dev-help@lists.php.net
To contact the list administrators, e-mail: php-list-admin@lists.php.net