Re: Consistent function names
| From: | Yasuo Ohgaki | Date: | Mon, 02 Mar 2015 01:30:29 +0000 |
| Subject: | Re: Consistent function names | ||
| References: | 1 2 3 4 5 6 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-84139@lists.php.net to get a copy of this message | ||
Hi all,
On Mon, Mar 2, 2015 at 9:55 AM, S.A.N <ua.san.alex@gmail.com> wrote:
> 2015-03-02 2:17 GMT+02:00 Terry Cullen <terry@terah.com.au>:
> > On 2 March 2015 at 01:18, S.A.N <ua.san.alex@gmail.com> wrote:
> >
> >> Maybe better implement for method calls on primitive types in PHP 7?
> >> https://github.com/nikic/scalar_objects
> >>
> >>
> > I've searched through the internals archive looking for debate on using
> > scalar objects without much luck. I'd love to see some discussion around
> > this as it seems like it would go a long way to resolving some common
> pain
> > points in PHP without BC like:
> >
> > - type hints
> > - inconsistant function naming
> > - needle/haystack
> > - unicode
> >
> > And, the method chaining of common string/array manipulations makes for
> > cleaner, easier to read code.
> >
>
> +1
I'm strong supporter for scalar objects also.
I still would like to clean up old function names, like phpversion()/etc.
I did this for pgsql module large object functions about 10 years ago.
It worked well enough. IMHO.
http://php.net/manual/en/function.pg-lo-open.php
pg_lo_open() was named pg_loopen(). The old name aliases, pg_loopen()/etc,
are
available now, too.
Regards,
--
Yasuo Ohgaki
yohgaki@ohgaki.net