Re: Consistent function names
| From: | Yasuo Ohgaki | Date: | Mon, 02 Mar 2015 22:53:00 +0000 |
| Subject: | Re: Consistent function names | ||
| References: | 1 2 3 4 5 6 7 8 9 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-84200@lists.php.net to get a copy of this message | ||
Hi Rowan,
On Tue, Mar 3, 2015 at 7:40 AM, Rowan Collins <rowan.collins@gmail.com>
wrote:
> The issue here is PHP will keep inconsistent names forever or not.
>> IMHO.
>>
>
> Have you noticed the slight contradiction here? You want to get rid of the
> inconsistent names, but you propose to keep the old, inconsistent, names
> around forever. And then you want to add more names, so that people can
> inconsistently use a different name for the same thing.
I should have written "PHP will keep _only_ inconsistent names forever or
not".
My proposal is to have consistent names that accord CORDING_STARNDARDS,
not eliminating inconsistent names.
Regards,
--
Yasuo Ohgaki
yohgaki@ohgaki.net