Re: Consistent function names

From: Date: Mon, 02 Mar 2015 23:02:36 +0000
Subject: Re: Consistent function names
References: 1 2 3 4 5 6 7 8 9 10  Groups: php.internals 
Request: Send a blank email to internals+get-84203@lists.php.net to get a copy of this message
On Mon, Mar 2, 2015 at 2:53 PM, Yasuo Ohgaki <yohgaki@ohgaki.net> wrote: > Hi Rowan, > > On Tue, Mar 3, 2015 at 7:40 AM, Rowan Collins <rowan.collins@gmail.com> > wrote: > >> The issue here is PHP will keep inconsistent names forever or not. >>> IMHO. >>> >> >> Have you noticed the slight contradiction here? You want to get rid of the >> inconsistent names, but you propose to keep the old, inconsistent, names >> around forever. And then you want to add more names, so that people can >> inconsistently use a different name for the same thing. > > > I should have written "PHP will keep _only_ inconsistent names forever or > not". > My proposal is to have consistent names that accord CORDING_STARNDARDS, > not eliminating inconsistent names. Seriously, let call them exceptions to the CS and move on. I do think that doing that will create even more mess that what we actually try to solve. For the extension, it is relatively easier to actually provide more clean and modern APIs when possible. For the core, leaving them like that is simply the best move. And let focus on the scalar object-like proposal. -- Pierre @pierrejoye | http://www.libgd.org

« previous php.internals (#84203) next »