Re: Consistent function names

From: Date: Wed, 04 Mar 2015 21:36:44 +0000
Subject: Re: Consistent function names
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-84306@lists.php.net to get a copy of this message
Hi Leigh, On Thu, Mar 5, 2015 at 4:30 AM, Leigh <leight@gmail.com> wrote: > On 1 March 2015 at 11:29, Yasuo Ohgaki <yohgaki@ohgaki.net> wrote: > > > > Thoughts? > > > > require 'function_aliases.php'; // End of discussion. > > Maintain it however you want, set it up as a composer package, > whatever. Absolutely no reason for this to be in core, and absolutely > not worth the trouble it causes. > > Sorry if this has already been said, but I'm not going to read 60 > replies, most of which are probably spam. > Your reply is not a spam at all. I will do require 'function_aliases.php'; // End of discussion. If PHP has macro or userspace aliasing! This is one possible solution for this. We have class_alias(). We could have function_alias(). Regards, P.S. We still carry inconsistent names only, though. We may be better do this in PHP. IMHO. -- Yasuo Ohgaki yohgaki@ohgaki.net

« previous php.internals (#84306) next »