Re: Consistent function names
| From: | Yasuo Ohgaki | Date: | Mon, 02 Mar 2015 22:59:28 +0000 |
| Subject: | Re: Consistent function names | ||
| References: | 1 2 3 4 5 6 7 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-84201@lists.php.net to get a copy of this message | ||
Hi Rowan,
On Tue, Mar 3, 2015 at 7:50 AM, Rowan Collins <rowan.collins@gmail.com>
wrote:
> On 02/03/2015 22:36, Yasuo Ohgaki wrote:
>
>> I like scalar objects, but it does not resolve that PHP has non standard
>> function names.
>> It does not change old names, therefore it's impossible to resolve issue..
>> This is the reason why I'm proposing while I like scalar object, use of
>> namespace, etc.
>>
>
> Again, you're contradicting yourself here - you can't say that your
> mission is to change the old names, rather than offer an alternative, but
> then also say that the old names will stay around forever. If both names
> exist, that's exactly what you've created - an alternative.
>
I think there is big difference between new API and alias.
Alias is just a copy, new API works differently.
> If we're going to have an alternative, let's come up with a creative
> alternative that actually has an advantage to using it, not a choice
> between equally cryptic names like "strripos" vs "str_ripos".
I don't like the name neither. I improved other names such as
"array_sort_assoc_reverse → arsort" ,
but I kept cryptic libc names.
Suggestions are appreciated for cryptic names.
I think "gettext_d" is equally bad, for example...
Regards,
--
Yasuo Ohgaki
yohgaki@ohgaki.net