[RFC] [VOTE] Short Closures
| From: | Bob Weinand | Date: | Tue, 22 Sep 2015 01:59:56 +0000 |
| Subject: | [RFC] [VOTE] Short Closures | ||
| Groups: | php.internals | ||
| Request: | Send a blank email to internals+get-88394@lists.php.net to get a copy of this message | ||
Hey,
Thanks for all your feedback in the discussion thread!
So, before I start the vote, just two quick notes:
I've added two notes about the statement syntax and the single variable use.
Though a few people complained, I'm not switching to the ==> operator, as I noticed many
people expected typehints to work (they don't due to parser limitations) when they compared to
Hack's short Closures. It also allows us to differ syntax-wise [e.g. for typehints] from Hack
without causing any confusion later. Which should be the smartest choice: Avoid conflicts. (If
anyone strongly feels against that, he may vote no, but I would like to not bikeshed that in this
Vote thread, but leave it free for eventual actual issues.)
Now, the link to the RFC about Short Closures:
https://wiki.php.net/rfc/short_closures
or straight ahead to the vote:
https://wiki.php.net/rfc/short_closures#vote
Thanks,
Bob