Re: [RFC] [VOTE] Short Closures

From: Date: Fri, 02 Oct 2015 06:33:52 +0000
Subject: Re: [RFC] [VOTE] Short Closures
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-88632@lists.php.net to get a copy of this message
Le 22/09/2015 03:59, Bob Weinand a écrit :
Hey, or straight ahead to the vote: https://wiki.php.net/rfc/short_closures#vote Thanks, Bob
Hi, After discussing this with other people at AFUP, we would be (a large majority of us) -1 on this RFC. Basically, we feel that: * This could lead to less readable code, mostly because of the usage of an operator (which is not, to some, "the PHP way") and because of the parenthesis / brackets that are optional in some cases * The "~>" operator has less meaning than "function" Keeping the old "function" syntax is, of course, nice and required -- but also means having two possible syntaxes for the same thing, which is less nice. BTW, the "automatically bind variables" didn't come up much in our discussion. And a few mentioned that "~>" could be a bit hard to type and could look a bit too similar to "->". In any case, thanks for your work on this! -- Pascal MARTIN, AFUP - French UG http://php-internals.afup.org/

« previous php.internals (#88632) next »