Re: Re: [RFC] [VOTE] Short Closures
| From: | Björn Larsson | Date: | Thu, 24 Sep 2015 21:31:20 +0000 |
| Subject: | Re: Re: [RFC] [VOTE] Short Closures | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-88488@lists.php.net to get a copy of this message | ||
Den 2015-09-22 kl. 17:16, skrev Andrea Faulds:
Hi Bob, Bob Weinand wrote:altgr+~+space to get the ~ sign. To get the $ sign one needs to push altgr+$, but $ is on the left of keyboard while ~ is on the right. So in my eyes the difficulty is similar. I find it more annoying though with the $ sign. Regards //BjörnHey, Thanks for all your feedback in the discussion thread! So, before I start the vote, just two quick notes: I've added two notes about the statement syntax and the single variable use. Though a few people complained, I'm not switching to the ==> operator, as I noticed many people expected typehints to work (they don't due to parser limitations) when they compared to Hack's short Closures. It also allows us to differ syntax-wise [e.g. for typehints] from Hack without causing any confusion later. Which should be the smartest choice: Avoid conflicts. (If anyone strongly feels against that, he may vote no, but I would like to not bikeshed that in this Vote thread, but leave it free for eventual actual issues.) Now, the link to the RFC about Short Closures: https://wiki.php.net/rfc/short_closures or straight ahead to the vote: https://wiki.php.net/rfc/short_closures#voteI am unhappy with the ~> syntax choice. As I've mentioned before, it's hard to type for many people, it looks too much like ->, and it's unnecessarily different from Hack's ==>, of which this RFC would otherwise be proposing a strict subset. So, I am voting against. Thanks. One a side-note using a nordic keyboard-layout one needs to push