#25876 [Fbk->Opn]: session_start(): Failed to initialize storage module
| From: | golden at riscom dot com | Date: | Fri, 17 Oct 2003 08:37:06 +0000 |
| Subject: | #25876 [Fbk->Opn]: session_start(): Failed to initialize storage module | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-49127@lists.php.net to get a copy of this message | ||
ID: 25876
User updated by: golden at riscom dot com
Reported By: golden at riscom dot com
-Status: Feedback
+Status: Open
Bug Type: Session related
Operating System: freebsd 4.8
PHP Version: 4.3.3
New Comment:
-bash-2.05b$ ls -l
drwxrwxrwt 4 root wheel 2048 Oct 17 11:37 tmp
Previous Comments:
------------------------------------------------------------------------
[2003-10-16 22:34:57] iliaa@php.net
Is the /tmp directory writeable by the web server and is there
avaliable space in there?
------------------------------------------------------------------------
[2003-10-15 07:03:06] golden at riscom dot com
Description:
------------
After migrating web server platform from win2000 to freebsd periodicly
this message appears in logs:
PHP Fatal error: session_start(): Failed to initialize storage module.
in index.php on line 5
PHP Warning: Unknown(): A session is active. You cannot change the
session module's ini settings at this time. in Unknown on line 0
I'm using now FreeBSD 4.8 and Apache 2.0.47
On the line 5 in index.php just a call session_start();
here's part of my config in php.ini:
session.auto_start Off
session.bug_compat_42 On
session.bug_compat_warn On
session.cache_expire 180
session.cache_limiter nocache
session.cookie_lifetime 0
session.cookie_path /
session.cookie_secure Off
session.entropy_length 0
session.gc_divisor 100
session.gc_maxlifetime 1440
session.gc_probability 1
session.name PHPSESSID
session.save_handler files
session.save_path /tmp
session.serialize_handler php
session.use_cookies On
session.use_only_cookies Off
session.use_trans_sid On
Reproduce code:
---------------
<?php
session_start();
session_register("m");
Expected result:
----------------
not to see this message in logs, see the page expected
Actual result:
--------------
PHP Fatal error: session_start(): Failed to initialize storage module.
in index.php on line 5
PHP Warning: Unknown(): A session is active. You cannot change the
session module's ini settings at this time. in Unknown on line 0
and we get just a blank page instead of seeing of what actually
expected
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=25876&edit=1