#25876 [Com]: session_start(): Failed to initialize storage module
| From: | helmut007 at gmx dot net | Date: | Sun, 06 Feb 2005 22:10:07 +0000 |
| Subject: | #25876 [Com]: session_start(): Failed to initialize storage module | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-73567@lists.php.net to get a copy of this message | ||
ID: 25876
Comment by: helmut007 at gmx dot net
Reported By: golden at riscom dot com
Status: Assigned
Bug Type: Session related
Operating System: freebsd 4.8
PHP Version: 4.3.9-4.3.10
Assigned To: sas
New Comment:
To the Bugreport: http://bugs.php.net/bug.php?id=31313
Derrick Rethans has supposed this Problem:
ID: http://bugs.php.net/bug.php?id=31624
Updated by: derick@php.net
Reported By: ericvanblokland at gmail dot com
-Status: Open
+Status: Feedback
Bug Type: Session related
Operating System: Fedora Core 2
PHP Version: 4.3.10
New Comment:
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
[...]
Previous Comments:
------------------------------------------------------------------------
[2005-01-30 13:30:41] nilson at hotmail dot com dot da dot ru
terrible bug keeps bugging me and loads of visitors over the whole
serverrange
take this bug (more) serious please!!!
------------------------------------------------------------------------
[2005-01-24 11:08:15] oliver at teqneers dot de
Correction:
The problem "Unknown(): A session is active. You cannot change the
session module's ini settings at this time. in Unknown on line 0" has
been solved by removing all "exit" statements from session handler as
well as from the scripts.
------------------------------------------------------------------------
[2005-01-24 10:58:15] oliver at teqneers dot de
We are using PHP 4.3.9 on a Win2003 Server with an IIS 6.0.
We also tried to use winenabler next to the cgi-version as well as an
Apache2, but the error still comes up ("Unknown(): A session is active.
You cannot change the session module's ini settings at this time. in
Unknown on line 0").
Since some scripts are trying to use a customer DB based session save
handler, other scripts experience problems with the standard files
session handler ("Fatal error: session_start(): Failed to initialize
storage module: user (path: ...)". It seems that once a php got its
session.save_handler settings changed, it remembers them and does not
switch back to standard settings as it should do. The second problem
appears to be random.
------------------------------------------------------------------------
[2005-01-18 23:14:03] helmut007 at gmx dot net
nobody of the programmers cares? ;)
------------------------------------------------------------------------
[2005-01-09 14:56:58] seefire_00 at yahoo dot com
The session handler directive on our server was pre-configured to use
'files' rather than 'user'. The problem still persists...
In addition, the /tmp folder is writeable.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/25876
--
Edit this bug report at http://bugs.php.net/?id=25876&edit=1