Re: Re: ctype function (re?)naming

From: Date: Wed, 07 Mar 2001 06:48:02 +0000
Subject: Re: Re: ctype function (re?)naming
References: 1 2 3 4 5 6  Groups: php.dev php.qa 
Request: Send a blank email to php-dev+get-48135@lists.php.net to get a copy of this message
Andi wrote: [snip] > Yep. Let's start doing some damage. bzip2 is a very good victim. bzclose -> bz_close bzcompress -> bz_compress bzdecompress -> bz_decompress bzerrno -> bz_errno bzerror -> bz_error bzerrstr -> bz_errstr bzflush -> bz_flush bzopen -> bz_open bzread -> bz_read bzwrite -> bz_write Can anyone see a problem with the proposed name changes? Do we need to do anything (other than warn people about the changes to the extension) for this particular case? >> Good point - perhaps a better solution would be to have compression >> library that uses switches to choose between bzip and gzip? It would >> be easy to bolt on other compression methods without having to do >> much additional documentation, etc... > > You could write a PEAR script for this but I don't think it has > anything to do with our current discussion :) True enough. Move along, nothing to see here... ;) >>>> EXIF >>>> read_exif_data >>> > >>> exif_read_data? >> >>Yep - we should fix this... > >Yep. As changes are proposed and accepted, we should keep track of them. I will keep a list of what is going on so that we don't have to continually dig through the archives. >>>> GMP (not in manual yet) >>>> gmp_abs >>>> gmp_add >>>> gmp_and >>>> gmp_clrbit -> gmp_clr_bit ? >>> >>> this_seems_a_little_long_gmp_clrbit_i_think_might_be_better. >> >> I prefer Andi's gmp_clear_bit > > hmm, so do I. Strange.... :) and it isn't even a full moon! ;) [snip][hack] >>>> ZZIPLIB >>>> zzip_close >>>> zzip_closedir -> zzip_close_dir >>> >>> no. >>> >>> closedir() --> zzip_closedir() >>> >>> I'd prefer to keep it close to the php name. >> >> Hrm... I prefer to separate things that most people percieve as being >> two words... but if I could waffle on (close|open)log, I can waffle >> on this. :) > > I don't think we need to be caught in the C API loop all the time. I > think if we'd start today without knowing libc we would call it > zzip_open_dir() or something like that. The underscore makes more > sense. As it is a new extension I think we could go with that > underscore. PHP abstracts C API's and doesn't necessarily have to be > the exact same thing as C. Anyone else? --zak

« previous php.dev (#48135) next »