Re: str_ireplace vs. stri_replace

From: Date: Thu, 30 Jan 2003 21:52:10 +0000
Subject: Re: str_ireplace vs. stri_replace
References: 1 2 3  Groups: php.dev 
Request: Send a blank email to php-dev+get-93815@lists.php.net to get a copy of this message
Hello, It looks like follow ereg is nice to me. Maybe we can have a FALIAS so we can have both? -- Regards. M.CHAILLAN Nicolas nicos@php.net www.WorldAKT.com Hébergement de sites internets. "Sara Golemon" <pollita@php.net> a écrit dans le message de news: 006601c2c8a8$c3b141f0$fb00000a@basillica... > > One little thingie: shouldn't it be called stri_replace() rather than > > str_ireplace() ? > > > You're not the first to voice this opinion. *I* feel str_ireplace is better > as it follows the naming convention of <module>_<function>. Others feel > stri_replace is better as that follows eregi_replace's style. I have no > trouble going with whatever the majority feels is best. > > Can we get a quick vote? > > -Pollita >

« previous php.dev (#93815) next »