Re: Re: str_ireplace vs. stri_replace

From: Date: Fri, 31 Jan 2003 05:25:38 +0000
Subject: Re: Re: str_ireplace vs. stri_replace
References: 1 2 3 4  Groups: php.dev 
Request: Send a blank email to php-dev+get-93831@lists.php.net to get a copy of this message
Well, if you're doing that, go ahead and change stristr() and strstr() too... And eregi() and ereg()... It should be done one way or another. Besides, wasn't one of the points in introducing this function that so many users were looking for it? "Jon Parise" <jon@php.net> wrote in message news:20030130215514.GC1722@csh.rit.edu... > On Thu, Jan 30, 2003 at 01:44:27PM -0800, Sara Golemon wrote: > > > You're not the first to voice this opinion. *I* feel str_ireplace is better > > as it follows the naming convention of <module>_<function>. Others feel > > stri_replace is better as that follows eregi_replace's style. I have no > > trouble going with whatever the majority feels is best. > > Get rid of stri_replace() and/or str_ireplace() and just add a fourth > optional parameter to str_replace() to control case-sensitivity. > > -- > Jon Parise (jon@php.net) :: The PHP Project (http://www.php.net/)

« previous php.dev (#93831) next »