Re: Re: str_ireplace vs. stri_replace

From: Date: Thu, 30 Jan 2003 22:00:17 +0000
Subject: Re: Re: str_ireplace vs. stri_replace
References: 1 2 3 4  Groups: php.dev 
Request: Send a blank email to php-dev+get-93817@lists.php.net to get a copy of this message
On Thu, 30 Jan 2003, Jon Parise wrote: > On Thu, Jan 30, 2003 at 01:44:27PM -0800, Sara Golemon wrote: > > > You're not the first to voice this opinion. *I* feel str_ireplace is better > > as it follows the naming convention of <module>_<function>. Others feel > > stri_replace is better as that follows eregi_replace's style. I have no > > trouble going with whatever the majority feels is best. > > Get rid of stri_replace() and/or str_ireplace() and just add a fourth > optional parameter to str_replace() to control case-sensitivity. +1 on that. Derick -- ------------------------------------------------------------------------- Derick Rethans http://derickrethans.nl/ PHP Magazine - PHP Magazine for Professionals http://php-mag.net/ -------------------------------------------------------------------------

« previous php.dev (#93817) next »