RE: [PHP-DEV] Re: str_ireplace vs. stri_replace
| From: | Timothy Hitchens \(HiTCHO\) | Date: | Thu, 30 Jan 2003 22:04:21 +0000 |
| Subject: | RE: [PHP-DEV] Re: str_ireplace vs. stri_replace | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-93819@lists.php.net to get a copy of this message | ||
Adding a parameter to an existing function is the way to go I agree.
Timothy Hitchens (HiTCHO)
Web Application Consulting
e-mail: tim@hitcho.com.au
> -----Original Message-----
> From: Derick Rethans [mailto:derick@php.net]
> Sent: Friday, 31 January 2003 8:00 AM
> To: Jon Parise
> Cc: Sara Golemon; PHP Developers Mailing List
> Subject: Re: [PHP-DEV] Re: str_ireplace vs. stri_replace
>
>
> On Thu, 30 Jan 2003, Jon Parise wrote:
>
> > On Thu, Jan 30, 2003 at 01:44:27PM -0800, Sara Golemon wrote:
> >
> > > You're not the first to voice this opinion. *I* feel
> str_ireplace
> > > is better as it follows the naming convention of
> > > <module>_<function>. Others feel stri_replace is better as that
> > > follows eregi_replace's style. I have no trouble going with
> > > whatever the majority feels is best.
> >
> > Get rid of stri_replace() and/or str_ireplace() and just
> add a fourth
> > optional parameter to str_replace() to control case-sensitivity.
>
> +1 on that.
>
> Derick
>
> --
>
> --------------------------------------------------------------
> -----------
> Derick Rethans
> http://derickrethans.nl/
> PHP Magazine - PHP Magazine for
> Professionals http://php-mag.net/
> --------------------------------------------------------------
> -----------
>
>
> --
> PHP Development Mailing List <http://www.php.net/>
> To unsubscribe, visit: http://www.php.net/unsub.php
>