Re: Re: str_ireplace vs. stri_replace

From: Date: Thu, 30 Jan 2003 21:55:15 +0000
Subject: Re: Re: str_ireplace vs. stri_replace
References: 1 2 3  Groups: php.dev 
Request: Send a blank email to php-dev+get-93816@lists.php.net to get a copy of this message
On Thu, Jan 30, 2003 at 01:44:27PM -0800, Sara Golemon wrote: > You're not the first to voice this opinion. *I* feel str_ireplace is better > as it follows the naming convention of <module>_<function>. Others feel > stri_replace is better as that follows eregi_replace's style. I have no > trouble going with whatever the majority feels is best. Get rid of stri_replace() and/or str_ireplace() and just add a fourth optional parameter to str_replace() to control case-sensitivity. -- Jon Parise (jon@php.net) :: The PHP Project (http://www.php.net/)

« previous php.dev (#93816) next »