Re: Re: str_ireplace vs. stri_replace

From: Date: Thu, 30 Jan 2003 22:11:53 +0000
Subject: Re: Re: str_ireplace vs. stri_replace
References: 1 2 3  Groups: php.dev 
Request: Send a blank email to php-dev+get-93818@lists.php.net to get a copy of this message
On January 30, 2003 04:55 pm, Jon Parise wrote: > On Thu, Jan 30, 2003 at 01:44:27PM -0800, Sara Golemon wrote: > > You're not the first to voice this opinion. *I* feel str_ireplace is > > better as it follows the naming convention of <module>_<function>. > > Others feel stri_replace is better as that follows eregi_replace's style. > > I have no trouble going with whatever the majority feels is best. > > Get rid of stri_replace() and/or str_ireplace() and just add a fourth > optional parameter to str_replace() to control case-sensitivity. +1 from me too, stri_replace sound like a function some users may have implemented them selves and we could end up breaking their code by introducing it. Ilia

« previous php.dev (#93818) next »