Re: New construct discussion Summary

From: Date: Sun, 11 Jul 2004 11:39:57 +0000
Subject: Re: New construct discussion Summary
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-11087@lists.php.net to get a copy of this message
--- Marc Richards <contact_marcos@yahoo.es> wrote: > 3) So this leaves a function call which begs two questions: > What do we call it, [snip] > These include: ifset(), ifelse(), ifexists() and [snip] > nvl(), ifnull() and coalesce() have been proposed because of > This currently leaves us with a hand full of names, including: > ifsetor(), firstset(), getval()/getvalue()/get_value() (Is > there a rule > about underscores in new function names?). I addition to these, and Guy N. Hurst's excellent suggestions, I thought I'd throw a few into the mix, just for the sake of ideas. fix() safe_init() discern() concretize() One wag here also suggested: php_variable_quantum_waveform_collapse() but the least said about that, the better ... Out of the above, I think fix() and safe_init() are the better ones, although they possibly run the risk of causing conflicts with existing code, and being initially misleading with regards to their purpose. If semantic clarity is the primary criterion, I don't think we'll do much better than ifsetor(). Semantically, though, fix() works in both senses and, importantly, is nice and short. regards, Cris ___________________________________________________________ALL-NEW Yahoo! Messenger - sooooo many all-new ways to express yourself http://uk.messenger.yahoo.com

« previous php.internals (#11087) next »