6.) Done, despite me hating $line{0} ... I think it's less readable,
though it is faster. I digress.
Please use $line[0] instead.
I'm thinking I'll leave it as $line{0}, though I might switch that to substr() for readability. Is $line an array? Is it a string? Who knows! Using $line[0] is a bit ambiguous. In fact, it appears the PHP docs use $line{0} so that's what I'll use.
http://www.php.net/manual/en/language.types.string.php
--Joe
--Justin Patrin
--
Joseph C. Stump
joe@joestump.net
http://www.joestump.net